使用易语言程序隐藏显示Proxyer运行窗口

  • 2020 年 09 月 28 日
  • 28次
  • 593 字
  • 暂无评论

前言:

继上上次修改win10家庭版远程桌面连接后又在上次写了通过Proxyer实现内网穿透,但在日常使用Proxyer的过程中发现始终会有个窗口在屏幕上 或 任务条 或是在 托盘图标,然而关闭之后内网穿透则失效,身为中度强迫症患者总感觉到有那么一丝丝的别扭,在网上找了n种后台运行的方法,自己尝试了n种方法都不能如我所愿,于是乎就自行编写了一个简单的易语言程序来实现该功能,大概流程图如下:

  1. 程序启动时隐藏自身。
  2. 判断Proxyer是否在后台运行中,在后台时继续执行,未在后台运行时先启动 Proxyer 等待1秒后再继续执行。
  3. Proxyer运行时:根据 Proxyer 当前窗口的显示隐藏属性修改为相反的属性,即 显示 = 隐藏;隐藏 = 显示。
  4. 结束自身运行。

以下为源代码可直接复制、直接下载源代码文件 自行修改需求使用哦,该代码使用了 精易模块[v8.1.5].ec 。

.版本 2
.支持库 shell
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 路径, 文本型
.局部变量 句柄, 整数型
.局部变量 可见, 逻辑型

' 设置当前程序窗口属性,也可以在 启动窗口 属性 页面设置
_启动窗口.可视 = 假
_启动窗口.在任务条中显示 = 假

路径 = 取特定目录 (6) + “Startup\Proxyer”
' C:\Users\Monkey0\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup\Proxyer

句柄 = 窗口_取句柄 (, , “ConsoleWindowClass”, “Proxyer”)
' 取出窗口句柄

.如果真 (句柄 = 0)
    ' 窗口句柄不存在时表示 程序 未运行 或 窗口类名、标题有误
    执行 (4, 路径, , , )
    延迟 (1000)
    句柄 = 窗口_取句柄 (, , “ConsoleWindowClass”, “Proxyer”)
    调试输出 (句柄)
.如果真结束

可见 = 窗口_是否可见 (句柄)
' 取出当前窗口是否可见

窗口_显示隐藏 (句柄, 取反 (可见))
' 根据当前窗口是否可见:修改为对应值;即 可见 设置为 不可见;不可见 设置为 可见

结束 ()
' 结束该程序 并非启动的程序 运行

看起来好像有点。。。还是放张图吧
Proxyer源码截图.jpg
源码下载
精易模块[v8.1.5].ec 请在网上下载(任意版本应该都可以用),如无法使用请留言。

运行录像:

Proxyer.mp4


版权属于:Houzi0

本文链接:https://houzi0.com/archives/12.html



—— 暂无评论 ——

OωO